Archive

Posts Tagged ‘amd’

Quad core AMD 8354 Barcelona 10h B2 and ESXi does not work thanks to a bug in the processor

September 27th, 2009 No comments

I discovered VMWare has a white paper on running nested vms. This is really cool and something I want to try.  If you read the document you’ll notice you are limited on what CPU you can use to accomplish this.  My home server had Opteron processors, but they aren’t the right generation.  I decided to search craigslist and see if maybe someone was off loading the processors I needed.  Wow, first hit I got really lucky.  Someone was selling quad core Opteron processors, Barcelona generation family 10H!  I drove an hour out and payed a very reasonable price for said processors.

After diligently cleaning the processors and heat sink, I buttoned up the server and pushed the power button.  ESXi goes about it’s usually boot sequence and I get a dreaded purple screen that reads:

VMWare ESXi 4.0.0 build 171294
 
The system has found a problem on your machine and cannot continue.
 
No supported microcode level for this stepping of
AMD Family 10h B2 Processer.

I thought maybe I had to reinstall ESXi with the processor change so I inserted the installation cd and tried that. Same error. A quick search for the above string yields a terrible news for me in a post from the VMWare Communities. The last poster on the thread has a link to a wikipedia article that details a bug which makes virtualization fail. My bios actually has a work around option for the B2 cpu’s, but again, same error.

I’m going to try an email AMD, but I’m guessing I am now the owner of two reasonably priced quad core paper weights.

Update: I am out of luck, but AMD did provide some information to help avoid processors with this bug. The TLB erratum affects all original Phenom and Opteron quad core revision BA and B2 processors. Most of these were pulled from the market and replaced with revision B3.

Categories: Uncategorized Tags: ,